Back to overview
Downtime

Real-time traffic is down

May 18, 2026 at 12:38pm UTC
Affected services
Bot connectivity EU
AI Agent platform EU
SIP connectivity EU
Phone numbers EU
Recording EU
Voice translation EU

Resolved
May 18, 2026 at 4:40pm UTC

The issue that affected around 30% of the Bot calls in the EU region was resolved

Created
May 18, 2026 at 12:38pm UTC

We’re currently investigating an issue affecting Bot connectivity in Live Hub Europe.
Our team is actively working on it, and we’ll share updates as soon as possible. Thank you for your patience.